summaryrefslogtreecommitdiffstatshomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix62
1 files changed, 31 insertions, 31 deletions
diff --git a/flake.nix b/flake.nix
index dcf48ef8..42747c1e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,41 +4,41 @@
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
+ flake-parts.url = "github:hercules-ci/flake-parts";
+
+ treefmt-nix = {
+ url = "github:numtide/treefmt-nix";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
};
outputs =
- {
- self,
- flake-utils,
- nixpkgs,
- }:
- flake-utils.lib.eachDefaultSystem (
- system:
- let
- pkgs = nixpkgs.legacyPackages.${system};
- in
- {
- devShell = pkgs.mkShell {
- packages = with pkgs; [
- codespell
- delve
- gh
- git
- go
- golangci-lint
- nixfmt-rfc-style
- nodePackages.prettier
- ];
+ { nixpkgs, ... }@inputs:
+ let
+ systems = inputs.flake-utils.lib.defaultSystems;
+ in
+ inputs.flake-parts.lib.mkFlake { inherit inputs; } {
+ inherit systems;
+
+ imports = [ inputs.treefmt-nix.flakeModule ];
+
+ perSystem =
+ { pkgs, system, ... }:
+ {
+ treefmt = import ./treefmt.nix { inherit pkgs; };
- shellHook = ''
- # Use //:.gitmessage as the commit message template
- ${pkgs.git}/bin/git config --local commit.template ".gitmessage"
+ devShells.default = pkgs.mkShell {
+ packages = with pkgs; [
+ codespell
+ delve
+ gh
+ git
+ go
+ golangci-lint
+ ];
- # Use a common, shared file as the default for running
- # git-blame with the `--ignore-revs` flag
- ${pkgs.git}/bin/git config --local blame.ignoreRevsFile ".git-blame-ignore-revs"
- '';
+ shellHook = builtins.readFile ./flake-hook.bash;
+ };
};
- }
- );
+ };
}