aboutsummaryrefslogtreecommitdiffstatshomepage
Commit message (Collapse)AuthorAge
* separate some test AuthPlugins to single filesremote-argumentcountPhy2020-03-08
| | | | created AuthDeletePlugin and AuthCaseInsensitivePlugin under dokuwiki\test\mock
* check RemoteException code in unit testsPhy2020-03-08
|
* add alternative support for PHP not throwing ArgumentCountError in remote/APiPhy2020-03-03
| | | | | | PHP 5.6 and 7.0 won't throw ArgumentCountError. In this case, we use set_error_handler on E_WARNING and throw exceptions if it's about argument missing.
* suppress argument missing warnings on remote API testPhy2020-03-03
| | | | | This makes sure PHPUnit won't convert warnings into exceptions, and thus behaves as the same as regular DokuWiki where E_NOTICE is suppressed.
* rename vague AuthPlugin used by remote and authdelete testsPhy2020-03-02
|
* add unit tests that check exception type on remote args missing for #2545Phy2020-03-02
|
* catch ArgumentCountError and return XML error message for remoteAPI, fixes #2545Phy2020-03-02
| | | | | | | | | This is caused by a PHP 7.1 change: https://www.php.net/manual/en/migration71.incompatible.php #migration71.incompatible.too-few-arguments-exception Previously call_user_func_array will make those missing arguments to NULL without throwing an exception.
* set default argument value for some of remote methodsPhy2020-03-02
| | | | | | most are array params and one int. Note that before if they were not present from the remote request, a null will be applied to the argument, so this is actually applying the correct data type on the arguments.
* Remove obsolete attributes at <script> tagPhy2020-03-02
| | | | | | | | | | | | Nowadays it is not necessary to specify "type" or "charset" attribute at <script> tag: 1. "type" attribute defaults to "application/javascript", so there is no need to specify that. The recent value "text/javascript" is obsolete in favor of the default "application/javascript", as stated e.g. here: https://www.iana.org/assignments/media-types/media-types.xhtml#text 2. "charset" attribute of the <script> tag defaults to encoding be the same as the encoding of the script element's node document. As DokuWiki's default encoding is "utf-8", there is no need to specify this encoding in external resources. See: https://html.spec.whatwg.org/multipage/scripting.html#the-script-element Manual merging, closes #2921. Co-Authored-By: petrkajzar <58340153+petrkajzar@users.noreply.github.com>
* Merge pull request #2991 from bleistivt/patch-2Andreas Gohr2020-02-28
|\ | | | | Show pencil symbol on preview
| * Show pencil symbol on previewbleistivt2020-02-28
|/
* Merge pull request #2990 from dokuwiki-translate/lang_update_1450_1582877913Henry Pan2020-02-28
|\ | | | | Translation update (no)
| * translation updateTorgeir Blesvik2020-02-28
|/
* Merge pull request #2989 from splitbrain/jquery-migrate-3.1Henry Pan2020-02-26
|\ | | | | jquery-migrate: replace on()/trigger() shorthand and use prop() for disabled attr
| * jquery-migrate: replace on()/trigger() shorthand and use prop() for disabled ↵Phy2020-02-23
|/ | | | | | attr Related to #1546.
* Merge pull request #2969 from splitbrain/workflowAdjustmentsAndreas Gohr2020-02-22
|\ | | | | GitHub workflow adjustments
| * Split out temporary code style excludesMichael Große2020-02-19
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Splitting them out allows for plugins to use _test/phpcs.xml as the basis for their own linting without having an overly permissive coding standard. Also, this makes it more obvious and painful that these are just intended as temporary exceptions and should be actually fixed. The rule `Generic.ControlStructures.InlineControlStructure.NotAllowed` has its comment adjust to make it clear that this is an intended deviation from the PSR-2/PSR-12 coding standard. The rule `PSR1.Classes.ClassDeclaration.MissingNamespace` has to remain in the DokuWiki coding standard as the plugin base classes can currently not reasonably be in namespaces.
| * Run code style checks on pull requests, tooMichael Große2020-01-21
| | | | | | | | | | This should make the code style checks also run on pull requests the come from forks. Maybe also on old pull requests?
* | Merge pull request #2983 from ssahara/extension-managerAndreas Gohr2020-02-20
|\ \ | | | | | | refactor Extension manager
| * | check linktype of bugtrackerURLSatoshi Sahara2020-02-20
| | | | | | | | | | | | The "report bugs" link in the plugin's home page may be located to the same page in some extensions.
| * | fix url parameter separator in gui::tabURL()Satoshi Sahara2020-02-19
| | |
| * | revert aliasing FormWriter classSatoshi Sahara2020-02-19
| | |
| * | lowercase variable nameSatoshi Sahara2020-02-19
| | |
| * | set action attribute for form tagsSatoshi Sahara2020-02-18
| | |
| * | label.block design compatibilitySatoshi Sahara2020-02-18
| | | | | | | | | | | | | | | render <br> after <input> tag inside <label class="block"> elements. to be compatible with Doku_Form::form_textfield(), form_filefield()
| * | fix bundled extension listSatoshi Sahara2020-02-16
| | |
| * | bugfix: not work enable/disable plugin buttonsSatoshi Sahara2020-02-15
| | |
| * | rewrite code using Form\Form classSatoshi Sahara2020-02-15
| | |
| * | coding styleSatoshi Sahara2020-02-15
| | |
| * | Merge remote-tracking branch 'upstream/master' into extension-managerSatoshi Sahara2020-02-12
| |\ \ | |/ / |/| |
* | | Merge pull request #2959 from splitbrain/fixDoku_ParserCompatAndreas Gohr2020-01-28
|\ \ \ | | | | | | | | Restore Doku_Parser backward compatibility
| * | | Restore some backwards compatibility for injected handlersMichael Große2020-01-22
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Some plugins, for example the move plugin, use their own handler class. We need to give these plugins time to adjust their code. This should restore the functionality of the move plugin. We still need to extract the handler class itself. It also adds another debug method for triggering the deprecation event, since none of the two existing methods are suitable here. This dbgCustomDeprecationEvent method should be used sparingly and only where the other two don't work. Co-authored-by: Phy <git@phy25.com>
| * | | Restore backwards compatibility for Doku_ParserMichael Große2020-01-22
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Apparently, #2358 introduced a breaking change to the constructor and usage of Doku_Parser, which broke some plugins, e.g. the move plugin in michitux/dokuwiki-plugin-move#176 This patch should restore the legacy behavior of this deprecated class.
* | | | Merge pull request #2974 from splitbrain/deferJSAndreas Gohr2020-01-28
|\ \ \ \ | | | | | | | | | | Defer javascript and add feature Flag
| * | | | Add feature flag for deferred javascriptMichael Große2020-01-26
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This adds a feature flag for the jQuery and main-js requests added in #2786 and #2958. This adds only a single feature flag since deferring jQuery without deferring the main javascript request is likely to cause errors and confusion. The feature flag defaults to "on" as this should be unproblematic except for a few plugins. Also, with this flag being on by default, it should see more usage and is more likely to uncover existing issues. This feature flag should be removed once this feature is deemed safe.
| * | | | CDN antibrakeRainbow Spike2020-01-26
| | | | | | | | | | | | | | | | | | | | | | | | | GooglePage Speed Insights rank up 5-10 points Otherwise, the browser render is waiting for loading and compiling big CDN script libraries
| * | | | Update template.phpRainbow Spike2020-01-26
|/ / / /
* | | | Better callable support in Event default actions (#2970)Michael Große2020-01-24
|\ \ \ \ | | | | | | | | | | Better callable support in Event default actions
| * | | | Better callable support in Event default actionsAndreas Gohr2020-01-22
| | |_|/ | |/| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Instead of parsing the passed callback ourselves, this patch relies on call_user_func_array() instead to call an Event's default action. This ensures all possible ways to define a callback (including static methods) can be used. This should fix a problem mentioned in #2943
* | | | Merge pull request #2972 from dokuwiki-translate/lang_update_1440_1579878904Henry Pan2020-01-24
|\ \ \ \ | | | | | | | | | | Translation update (nl)
| * | | | translation updatePBU2020-01-24
|/ / / /
* | | | Merge pull request #2971 from dokuwiki-translate/lang_update_1439_1579813735Henry Pan2020-01-23
|\ \ \ \ | | | | | | | | | | Translation update (sr)
| * | | | translation updateЖељко Тодоровић2020-01-23
|/ / / /
* | | | Merge pull request #2946 from leimerp/patch-1Henry Pan2020-01-22
|\ \ \ \ | |_|/ / |/| | | allow windows shares for Edge browser
| * | | allow windows shares for Edge browserleimerp2019-12-30
| | | |
* | | | ♻️ Rename flag to better show actual effectMichael Große2020-01-22
| |/ / |/| | | | | | | | | | | This flag only causes parameters with empty strings to be skipped, not all empty() values.
* | | Sort plugins in Config Manager and Extension Manager (#2893)Michael Große2020-01-20
|\ \ \ | | | | | | | | Sort plugins in Config Manager and Extension Manager
| * | | create PluginUtils.test.phpSatoshi Sahara2020-01-20
| | | |
| * | | Merge remote-tracking branch 'upstream/master' into plugin-listSatoshi Sahara2020-01-20
| |\ \ \
| * | | | fix php errorsSatoshi Sahara2019-10-23
| | | | | | | | | | | | | | | | | | | | remove unnecessary "public"