aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e30674f31cd..e47b2ab9095 100644
--- a/setup.py
+++ b/setup.py
@@ -848,7 +848,9 @@ class PyBuildExt(build_ext):
tmpfile = os.path.join(self.build_temp, 'ccpaths')
if not os.path.exists(self.build_temp):
os.makedirs(self.build_temp)
- ret = run_command('%s -E -v - </dev/null 2>%s 1>/dev/null' % (CC, tmpfile))
+ # bpo-38472: With a German locale, GCC returns "gcc-Version 9.1.0
+ # (GCC)", whereas it returns "gcc version 9.1.0" with the C locale.
+ ret = run_command('LC_ALL=C %s -E -v - </dev/null 2>%s 1>/dev/null' % (CC, tmpfile))
is_gcc = False
is_clang = False
in_incdirs = False