aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 174ce720c80..8c13cf29a08 100644
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,7 @@ def find_module_file(module, dirlist):
if not list:
return module
if len(list) > 1:
- log.info("WARNING: multiple copies of %s found"%module)
+ log.info("WARNING: multiple copies of %s found", module)
return os.path.join(list[0], module)
class PyBuildExt(build_ext):
@@ -2007,7 +2007,7 @@ class PyBuildExt(build_ext):
break
ffi_lib = None
if ffi_inc is not None:
- for lib_name in ('ffi_convenience', 'ffi_pic', 'ffi'):
+ for lib_name in ('ffi', 'ffi_pic'):
if (self.compiler.find_library_file(lib_dirs, lib_name)):
ffi_lib = lib_name
break
@@ -2060,7 +2060,7 @@ class PyBuildExt(build_ext):
'_decimal/libmpdec/fnt.h',
'_decimal/libmpdec/fourstep.h',
'_decimal/libmpdec/io.h',
- '_decimal/libmpdec/memory.h',
+ '_decimal/libmpdec/mpalloc.h',
'_decimal/libmpdec/mpdecimal.h',
'_decimal/libmpdec/numbertheory.h',
'_decimal/libmpdec/sixstep.h',
@@ -2213,7 +2213,7 @@ class PyBuildScripts(build_scripts):
newfilename = filename + fullversion
else:
newfilename = filename + minoronly
- log.info('renaming {} to {}'.format(filename, newfilename))
+ log.info('renaming %s to %s', filename, newfilename)
os.rename(filename, newfilename)
newoutfiles.append(newfilename)
if filename in updated_files:
@@ -2255,7 +2255,7 @@ def main():
setup(# PyPI Metadata (PEP 301)
name = "Python",
version = sys.version.split()[0],
- url = "http://www.python.org/%s" % sys.version[:3],
+ url = "http://www.python.org/%d.%d" % sys.version_info[:2],
maintainer = "Guido van Rossum and the Python community",
maintainer_email = "python-dev@python.org",
description = "A high-level object-oriented programming language",